Apache using 1 of 8 core

Hello,

I installed AUTOVM correctly and everything works fine, but apache is consuming 100% CPU and only one core as shown:

You have to make sure you are using Apache’s worker MPM, rather than the prefork one. Depending on your installation, you may simply be able to symbolically link /usr/sbin/httpd2 to /usr/sbin/httpd2-worker (or wherever it is installed).

Of course, in your case, you could also just increase the number of maximum processes in your config, which should enable you to open multiple tabs and have them run at the same time.

Something like this:

StartServers       2
MinSpareServers    2
MaxSpareServers    8
ServerLimit        8
MaxClients         8
KeepAlive off